В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
laf03
laf03
09.03.2021 08:37 •  Информатика

Напишите программу на паскале
Дано неотрицательное целое N. Найти сумму и количество цифр в
системе счисления с основанием q.
q=2

Ответ:
Vadimlvo11
Vadimlvo11
27.12.2020 06:45

var

 i, p, n, q, sum: integer;

 a : array[1..1000000] of byte;

begin

 Write('Введите число N: ');

 ReadLn(n);

 Write('Введите основание системы счисления q: ');

 ReadLn(q);

 p := n;

 while p > 0 do

   begin

     i := i + 1;

     a[i] := p mod q;

     sum := sum + a[i];

     p := p div q;

   end;

 Write(n,'(10) = ');

 for p := i downto 1 do

   Write(a[p]);

 WriteLn('(', q, ')');

 WriteLn('Сумма цифр полученного числа равна ', sum);

 WriteLn('Количество цифр полученного числа равна ', i);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?