В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
6yterffjdjd
6yterffjdjd
04.11.2022 04:59 •  Информатика

Составить программу для вычисления значения функции y для заданного значения x у= если x< -3 то y= √1 - x² если 1,51,5, то y=tg x составить словесное описание алгоритма, составить блок схему, описать используемые элементы

Ответ:
Ychenik1354
Ychenik1354
12.06.2020 08:19

var
x,y:real;
begin
readln(x);
if x<-3 then
y:=sqrt(1)-x*x
else if (x>=-3) and (x<=1.5) then
y:=1/(abs(x+2))
else if x>1.5 then
y:=sin(x)/cos(x);
writeln(y);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?