В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alina3013
alina3013
22.10.2021 08:37 •  Информатика

Написать программу нахождения количества нечетных значений элементов массива больше 25 и меньше 99. ​

Ответ:
Ulugbek9i
Ulugbek9i
12.02.2021 18:35

begin

 var size := readinteger;

 var arr := ArrRandomInteger(size, -100, 100);

 arr.Println;

 var quantity := 0;

 for var i := 0 to arr.Length - 1 do

 begin

   if (arr[i] > 25) and (arr[i] < 99) and (arr[i] mod 2 <> 0) then

   begin

     inc(quantity);

   end;

 end;

 write(quantity);

end.

Объяснение:

begin  // Начало программы

 var size := readinteger;   // Переменная, хранящая размер массива, считывается с клавиатуры

 var arr := ArrRandomInteger(size, -100, 100);  // Объявление массива размером size + заполнение массива случайными значениями из диапазона [-100, 100].

 arr.Println;  // Вывод массива

 var quantity := 0;  // Переменная, хранящая количество элементов, равна 0

 for var i := 0 to arr.Length - 1 do  // Идём от нуля до размера массива - 1

 begin  // Начало цикла

   if (arr[i] > 25) and (arr[i] < 99) and (arr[i] mod 2 <> 0) then  // Если значение массива с индексом i > 25 И < 99 И нечетное, тогда

  begin  // Начало условного оператора

   begin  // Начало условного оператора

     inc(quantity);  // Увеличиваем значение переменной quantity на единицу

   end;  // Конец условного оператора

 end;  // Конец цикла

 write(quantity);  // Выводим ответ

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?