В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
скули
скули
22.02.2022 03:45 •  Информатика

Составить программу в паскале.даны три положительных числа а,в,с. проверить, могут ли быть они длинами сторон треугольник. если да, то вычислить площадь треугольника. (нужно учитывать, что стороны не могут равняться нулю. и возможно существование равностороннего треугольника) основные формулы: а< =б+с, б

Ответ:
smirnovigor
smirnovigor
12.06.2020 06:31

var a,b,c,p:integer;
begin
  writeln('введите a');
   readln(a);
  writeln('введите b');
   readln(b);
  writeln('введите c');
   readln(c);
  if (a<=b+c) and (b<a+c) and (c<=a+b) then
    begin
       p:=(a+b+c) div 2;
       writeln('Треугольник может существовать');
       writeln('Площадь: ', sqrt(p* ((p-a)*(p-b))*((p-c))):1:2);  //Формула герона
    end
  else writeln('Не треугольник');
  readln();
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?