В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arsenteva99i
arsenteva99i
22.03.2020 10:26 •  Информатика

Напишите программу, которая считывает 5 целых чисел, каждое на одной строке записывает их в массив и печатает этот массив наоборот на одной строке через пробелы. Использовать функции (readln, write, for downto). Пример Ввод

1

2

3

4

5

Вывод

5 4 3 2 1

Ответ:
viking0899
viking0899
22.12.2020 19:57

program z1;

var i: integer;

a:array [1..5] of integer;

begin

for i := 1 to 5 do readln (a[i]);

for i := 5 downto 1 do write (a[i],'  ')

end.

Объяснение:

Цикл со счётчиком:

for i := a to b do, где a <= b (от меньшего к большему)

for i := a downto b do, где a >= b (от большего к меньшему)

readln - ввод следующей строки с новой строки

write - вывод следующей строки с этой же строки

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?