В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
onaleman
onaleman
28.07.2022 00:47 •  Информатика

Написать программу на языке паскаль. Ввести с клавиатуры число N, 1>=N<=3. В зависимости от введенного числа вычислить и выдать на экран значения функции,
1) у = sin (п)
2) y = cos (п)
3) y = tg (п)
Если введено другое число - выдать сообщение об ошибке.

Ответ:
Никита0234632
Никита0234632
21.12.2020 07:59

Объяснение:

Var

N:integer;

a,b,c:real;

Begin

Writeln( ' Введите число N ');

Readln(N);

If ((N>=1)AND(N<=1)) then

begin

a:= sin(N);

b:=cos(N);

c:= a / b;

Writeln( ' sin(N) = ' , a);

Writeln( ' cos(N) = ' , b);

Writeln ( ' tg(N) = , c) ;

end;

If ((N<1)AND(N>3)) then

Writeln( ' Ошибка: Данные введены неверно' );

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?