В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
09Sodlatov
09Sodlatov
06.06.2022 12:45 •  Информатика

Напишите программу. Паскаль.
Вывести квадрат 5х5 из чисел от 1 до 25 “змейкой”. В первой строке
от 1 до 5, во второй от 10 до 6, в третьей 11 до 15 и т.д.

Ответ:
холера678
холера678
12.02.2021 18:09

const

 n = 5;

var

 a: array[1..n, 1..n] of integer;

 k, c, i, j: integer;

begin  

 c := 1;

 k := 1;

 while c <= n do  

 begin

   for i := 1 to n do  

     begin  

       a[c, i] := k;

       k := k + 1;  

     end;  

   c := c + 1;

   if c>n then break;

   for i := n downto 1 do  

     begin  

       a[c, i] := k;

       k := k + 1;  

     end;  

   c := c + 1;

 end;

 for i := 1 to n do  

   begin

     for j := 1 to n do  

       write(a[i, j]:3);

     writeLn;

   end;  

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?