В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

составить программу. Вводятся 2 числа a и b. Где а- натуральное число, b-число от 1 до 9. С цикла найти сколько раз число b встречается внутри числа а.

Пример:

а=3464 b=4

Результат 2 (раза)

Через Паскаль.

Var
Begin Readln и тд

Ответ:
Влад1111111111111121
Влад1111111111111121
16.12.2020 14:46

program z1;

var a,b,k: integer;

begin

k:=0;

write ('a = ');

read(a);

write ('b = ');

read(b);

while a > 0 do

begin

if a mod 10 = b then k:=k+1;

a:=a div 10

end;

write('Результат ',k)

end.

Объяснение:

Вводим числа

Цикл с предусловием

Если последняя цифра числа а равна числу b, то значение k увеличиваем на 1

Изменяем значение а, на целый результат деления на 10

Вывод значения k

mod - остаток от целочисленного деления

div - целочисленное деление

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?