В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
seilkhan2006
seilkhan2006
27.12.2020 14:14 •  Информатика

Составьте программу,которая нарисует квадрат со стороной a и окружность,вписанную в квадрат

Ответ:
Yoongikookie
Yoongikookie
11.06.2020 22:52

uses graphabc;
var a: integer;
begin
write('Введите сторону квадрата: ');
read(a);
clearwindow;
rectangle(50,50,50+2*a,50+2*a);
circle(50+a,50+a,a);
end.

Программа должна работать, но есть одно "но": она рисует квадрат со стороной 2а вместо а. Такие дела :) Надеюсь, что не критично.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?