В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Aldatik
Aldatik
22.06.2022 06:02 •  Информатика

Напишите программу: вычислить площадь N прямоугольных треугольников,если известна длина катетов. Кол-во треугольников задается в начале программы. Катеты задаются внутри цикла каждый раз новые.

Ответ:
BlueEyesCatОоак
BlueEyesCatОоак
13.12.2020 00:48

program z1;

var a,b: real;

n,i:integer;

begin

write('Введите количество прямоугольных треугольников: ');

readln(n);

for i:=1 to n do

begin

writeln;

writeln(i,' треугольник');

write('Введите первый катет прямоугольного треугольника: a = ');

readln(a);

write('Введите второй катет прямоугольного треугольника: b = ');

readln(b);

writeln('Площадь ',i,' треугольника: S = ',a*b/2);

end

end.

Объяснение:

Ввод количества треугольников

Цикл с параметром

Ввод первого катета

Ввод второго катета

Вывод площади

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?