В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ivandawidov
ivandawidov
21.08.2020 13:07 •  Информатика

составить программу на СИ, пользователь вводит строку, в которой все заглавные символы которые он введёт будут преобразованы в прописные

Ответ:
nifirazifira
nifirazifira
12.12.2020 21:45

Код программы:

#include <locale>

#include <stdio.h>

int main() {

setlocale(LC_ALL, "Russian");

char str[500];

int i;

printf("Введите строку:\n");

fgets(str, 500, stdin);

for (i = 0; i < strlen(str); i++) {

 if (isupper(str[i]))

  str[i] = tolower(str[i]);

}

printf("\nПреобразованная строка: %s", str);

       return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?