В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
seman6501
seman6501
27.05.2021 21:48 •  Информатика

Напишите программу вычисления выражения в программе Паскаль АБС
y = x^4 - 3x^3 + 5x - 6

Ответ:
vanyura
vanyura
11.12.2020 17:33

program expression;

var

 x, y: real;

begin

 read(x);

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;

 write(y);

end.

Объяснение:

program expression;  // Название программы

var

 x, y: real;  // Две переменные являются вещественными (требуется для power)

begin  // Начало программы

 read(x);  // Вводим число с клавиатуры

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;  // Само выражение

power(число, которое нужно возвести в степень | сама степень)

power(x, 4)

x - число

4 - степень

 write(y);  // Выводим ответ

end. // Начало программы

0,0(0 оценок)
Ответ:
maksosipow
maksosipow
11.12.2020 17:33

##

var x := ReadReal;

var y := -6 + x * (5 + x * (0 + x * (-3 + x))); // схема Горнера

Print(y)


Напишите программу вычисления выражения в программе Паскаль АБС y = x^4 - 3x^3 + 5x - 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?