В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ksapko
ksapko
03.04.2022 20:25 •  Информатика

Составьте программу вычисления в массиве a(n) произведения четных элементов.

Ответ:
куколку
куколку
11.06.2020 20:21

var
    a: array [1..100] of integer;
    i, p, n: integer;

begin
    p := 1;
    read(n);
    
    for i := 1 to n do
    begin
        read(a[i]);
        if a[i] mod 2 = 0 then
            p := p * a[i];
    end;
    
    writeln(p);
end.

0,0(0 оценок)
Ответ:
inybax
inybax
11.06.2020 20:21

program csdnciuo;

uses crt;

'var a:array [1..100] of integer;

       i,p,n:integer;

begin

clrscr;

readln(n);

for i:=1 to n do

readln(a[i]);

p:=1;

for i:=1 to n do

if a[i] mod 2 =0 then p:=p*a[i];

writeln(p);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?