В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sarah205681
sarah205681
08.03.2021 06:42 •  Информатика

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное среди них.ничего кроме этого программа выводить не должна. при использовании системы free pascal для представления целых чисел используйте тип longint. надо сделать в pascal

Ответ:
никто271
никто271
11.06.2020 19:23

var

  a, b, c, d, t1, t2:longint;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  write('c = '); readln(c);

  write('d = '); readln(d);

  if a < b then

    t1 := a

  else

    t1 := b;

  if c < d then

    t2 := c

  else

    t2 := d;

  if t1 < t2 then

    writeln('Min = ', t1)

 else

    writeln('Min = ', t2);

  readln;

end.

 

0,0(0 оценок)
Ответ:
egork9957
egork9957
11.06.2020 19:23

var

a,b,c,d,max:longint;

begin

  read(a); read(b); read(c); read(d);

  min:=a;

  if min>b then min:=b;

  if min>c then min:=c;

  if min>d then min:=d;

  writeln(min);

end.

 

Программа работает, проверено мной.)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?