В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hoylli333
hoylli333
04.05.2023 05:32 •  Информатика

В магазине продаются гвозди в ящиках по q, w, e, r килограмм. Напишите программу на питоне которая определяет как купить ровно X кг, не вскрывая ящики.

Ответ:
JR123
JR123
10.12.2020 10:05

X=30

q=1

w=2

e=3

r=4

list=[q,w,e,r]

for i in list:

   if i==X and i==q:

       print(f'Нужен ящик q')

   if i==X and i==w:

        print(f'Нужен ящик w')

   if i==X and i==e:

        print(f'Нужен ящик e')

   if i==X and i==r:

        print(f'Нужен ящик r')    

if e+r==X:

   print(f'Нужны ящики e и r')

if w+r==X:

   print(f'Нужны ящики w и r')

if w+e==X:

   print(f'Нужны ящики w и e')

if q+r==X:

   print(f'Нужны ящики q и r')

if q+e==X:

   print(f'Нужны ящики q и e')

if q+w==X:

   print(f'Нужны ящики q и w')

if w+e+r==X:

   print(f'Нужны ящики w, e и r')

if q+e+r==X:

   print(f'Нужны ящики q, e и r')

if q+w+r==X:

   print(f'Нужны ящики q, w и r')

if q+w+e==X:

   print(f'Нужны ящики q, w и e')

else:

   print('Нет таких ящиков')

Объяснение:

В кратце: я предполагаю, что количество ящиков по 1шт (q,w,e,r). Далее я пробегаюсь по всем возможных вариантам, каким образом можно получить из q,w,e,r X кг

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?