В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

с Питоном. Составить программу, позволяющую в одномерном массиве, состоящем из N случайно заданных элементов, вычисляющую указанное ниже значение. . Варианты вычисляемых значений:
1) сумма модулей отрицательных элементов массива;
2) количество положительных элементов массива;
3) количество элементов массива, не принадлежащих интервалу (a, b);
4) произведение элементов массива, меньших десяти

Ответ:
veronikavolkova357
veronikavolkova357
05.12.2020 11:59

как-то так

N = int(input('Кол-во элементов: '))

A = int(input('Начало интервала: '))

B = int(input('Конец интервала: '))

arr = [int(input()) for _ in range(N)]

sum_, countPos, countInt, comp = 0, 0, 0, 0

for i in arr:

 if i < 0:

   sum_ += abs(i)

 if i > 0:

   countPos += 1

 if i < A or i > B:

   countInt += 1

 if i < 10:

   if comp == 0:

     comp = i

   else:

     comp *= i

print(f'1. {sum_}\n2. {countPos}\n3. {countInt}\n4. {comp}')

0,0(0 оценок)
Ответ:
Сменка
Сменка
05.12.2020 11:59

Написал всё так же в одной программе.

Указываешь N, затем через пробел a и b, а после сам массив из N символов.

Всё красиво выведется.

Просто не увидел, что ответ уже пишут.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?