В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yasmina2534
yasmina2534
11.05.2021 07:57 •  Информатика

Написать программу, которая находит сумму четных чисел до ввода цифры 0.

Ответ:
ляятупой
ляятупой
04.12.2020 22:53

#include <iostream>

#include <vector>

using namespace std;

void solve(){

   int sum = 0;

   while(true){

       int x;

       cin >> x;

       if(x == 0)

           break;

       sum += (x % 2 == 0) * x;

   }

   cout << sum;

}

signed main(){

   solve();

}

0,0(0 оценок)
Ответ:
Gagoro
Gagoro
04.12.2020 22:53

program z1;

var a,s:integer;

begin

a:=-1;

s:=0;

while a <> 0 do

begin

write('a = ');

readln(a);

if a mod 2 = 0 then s:=s+a

end;

write('s = ', s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?