В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
loser80
loser80
16.08.2022 15:38 •  Информатика

Напишите программу в паскале, которая на ввод времени суток выводит соответствующее пожелание доброго утра, доброго дня, доброго вечера или спокойной ночи.

Ответ:
viktr1
viktr1
11.06.2020 15:16

Var m:integer;

Begin

Read(m);

if m>24 then write('takogo ne syschestvyet');

if  ((m<=6) and (m<=12))  then writeln('dobroe ytro');

if ((m>12) and (m<=18))  then writeln('dobruy den');

if ((m>18) and (m<=21))  then writeln('dobruy vecher');

if ((m>21) or (m<6)) then writeln('spokoyniy nochi');

End.

Я проверила . Все работает.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?