В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Maxxxx123
Maxxxx123
03.04.2023 17:33 •  Информатика

47. дано целое четырехзначное положительное число n. составьте программу,которая определяет,какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n. составьте программу, которая определяет, кратно ли пяти произведение его цифр

Ответ:
Vadimka221105
Vadimka221105
11.06.2020 14:48

var

  n:integer;

begin

  write('n = ');

  readln(n);

  if (n mod 10) > ((n div 100) mod 10) then

    writeln('Последняя больше второй')

  else

    if (n mod 10) < ((n div 100) mod 10) then

      writeln('Вторая больше последней')

    else

      writeln('Они равны');

  readln;

end.

 

 

 

// Вторая программа

var

  n, Pr:integer;

begin

  write('n = ');

  readln(n);

  Pr := 1;

  while n > 0 do

  begin

    Pr := Pr * (n mod 10);

    n := n div 10;

  end;

  writeln('Pr = ', Pr);

 

  if Pr mod 5 = 0 then

    writeln('Кратно')

  else

    writeln('Некратно');

  readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?