В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Кама29102007
Кама29102007
19.03.2022 02:21 •  Информатика

1.составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных элементов настоящей таблице х [1 .. 10] на 0. 3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат. 4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

Ответ:
Сложное123
Сложное123
11.06.2020 13:17

//первая программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    inc(x[i]);
  end;
 
  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

 

 

 

//вторая программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    if x[i] > 0 then
      x[i] := 0;
  end;

  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

 

 

 

// третья программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    if x[i] < 0 then
      x[i] := x[i] * x[i];
  end;

  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

 

 

 

// четвертая программа

 

var
  x:array[1..10] of integer;
  i:integer;
begin
  for i := 1 to 10 do
  begin
    write('x[', i, '] = ');
    readln(x[i]);
    if x[i] > 10 then
      x[i] := x[i] + 2;
  end;

  writeln;
  writeln('Result');
  for i := 1 to 10 do
    write(x[i], ' ');
  readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?