В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lesnichka1980
lesnichka1980
23.12.2022 05:49 •  Информатика

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел

Ответ:
vlada365
vlada365
11.06.2020 12:50

Program MAXOF3;

 

Var a,b,c,t,max: Real;

 

Begin

    Writeln('Type 3 different numbers');

    Write('a = '); Read(a);

    Write('b = '); Read(b);

    Write('c = '); Read(c);

    t := (a+b)/2 + abs(a-b)/2; {abs(x) - модуль числа х}

    max := (t+c)/2 + abs(t-c)/2;

    Writeln('max = ', max:2); {:2 - количество знаков после запятой}

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?