В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ddaaww
ddaaww
15.04.2022 04:08 •  Информатика

Написать программу на Pascale, параметры задачи на слайде.


Написать программу на Pascale, параметры задачи на слайде.

Ответ:
zed1111122
zed1111122
29.11.2020 10:55

program z1;

var z:array [1..18] of integer;

k,s:integer;

begin

randomize;

s:=0;

write ('Одномерная матрица: ');

for k:=1 to 18 do

begin

z[k]:=random(51)-25;

write (z[k]:5);

s:=s+z[k]

end;

writeln;

write ('s = ',s)

end.

Объяснение:

s:=s+z[k]  - сумма всех элементов матрицы (переменная k не учитывается)

если надо учитывать и переменную k - s:=s+z[k]+k

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?