В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tanyaprokudina
tanyaprokudina
26.08.2020 00:09 •  Информатика

И ОБЪЯСНИТЕ ПОДРОБНО: Дано трехзначное число. Напишите программу, которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые:
Пример входных данных Пример выходных данных
123 Нет
121 Да
222 Да

Я не понимаю как это делать

Ответ:
mlp1231
mlp1231
28.11.2020 15:50

program same;

var

 number: string;

begin

 read(number);

 if ((number[1] = number[2]) or (number[2] = number[3]) or (number[1] = number[3])) then

   writeln('Да')

 else

   writeln('Нет');

end.

Объяснение:

program same;  // Название программы

var

 number: string;  // Создание строковой переменной number

begin  // Начало программы

 read(number);  // Считываем значение переменной number с клавиатуры

 if ((number[1] = number[2]) or (number[2] = number[3]) or (number[1] = number[3])) then  // Если ((1 цифра = 2 цифре) ИЛИ (2 цифра = 3 цифре) ИЛИ (1 цифра = 3 цифре))

   writeln('Да')  // Выводим Да

 else  // Иначе

   writeln('Нет');  // Выводим Нет

end. // Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?