В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nick149
nick149
03.05.2023 08:48 •  Информатика

Составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел на среднюю этих чисел help ! please

Ответ:
karinalbi
karinalbi
11.06.2020 08:52

program lkcfndsl;

uses crt;

var a,b,s,g:real;

begin

clrscr;

readln(a,b);

s:=(a+b)/2;

g:=sqrt(a*b);

if a>b then a:=g else a:=s;

if b>a then b:=g else b:=s;

writeln(a,b);

readln;

end.

Надеюсь так понял.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?