В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
salatinabbasova
salatinabbasova
01.01.2020 18:50 •  Информатика

Написать программу по задаче: Сформировать массив из 12 элементов случайными числами от 0 до 30. Заполнить массив с клавиатуры и вывести на экран значения элементов массива в строчку.

Ответ:
вопросник45
вопросник45
27.11.2020 17:49

Если введенный с клавиатуры режим будет равен "1", то массив нужно будет заполнить вручную, если режим будет равен любому другому положительному числу, то массив заполнится случайными числами и выведется на экран.

Объяснение:

#include <iostream>

#include <ctime>

int main()

{

using namespace std;

setlocale(LC_ALL, "ru");

srand(time(0));

uint16_t arr[12];

int regim;

cout << "Введите режим: " << endl;

cin >> regim;

if (regim == 1)

{

 for (uint16_t i = 0; i < 12; i++)

  cin >> arr[i];

 for (uint16_t i = 0; i < 12; i++)

  cout << arr[i] << '\t';

}

else

{

 for (uint16_t i = 0; i < 12; i++)

 {

  arr[i] = rand() % 30;

  cout << arr[i] << '\t';

 }

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?