В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vladislav4239
vladislav4239
06.10.2021 00:24 •  Информатика

Паскаль. составить программу вычисления площади треугольника по любой из 3 известных формул(в программе должны использоваться все 3 на выбор). сами формулы пишу уже 2-ой раз!

Ответ:
dashkevich672
dashkevich672
11.06.2020 07:07

var S,a,b,c,p,p1,h:real;
k:integer;
begin
write('Kakoy sposob viberem(1,2,3)?');
read(k);
if k=1 then begin
writeln('Vvedite a,h');
read(a,h);
S:=(a*h)/2;
end;
if k=2 then begin
writeln('Vvedite a,b,c');
read(a,b,c);
S:=(Sin(c*Pi/180)*a*b)/2;
end;
if k=3 then begin
writeln('Vvedite a,b,c');
read(a,b,c);
p1:=1/2*(a+b+c);
S:=sqrt(p1*(p1-a)*(p1-b)*(p1-c));
end;
writeln(S);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?