В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу, которая находит первую позицию пробела в строке s, А ЗАТЕМ ПРОВЕРЯЕТ, есть ли еще пробелы в данной строке. Строка вводится с клавиатуры. паскальабс

Ответ:
qwertzasd
qwertzasd
26.11.2020 20:24

var

s: string;

i,dop: integer;

begin

writeln('Введите строку:');

readln(s);

writeln(pos(' ', s));

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Если нужно вывести ВСЕ пробелы, то:

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Проверка на наличие 2+ пробелов (размещать в конце (перед end.)):

if i > 3 then

 write('Пробелы ещё есть')

else

 writeln('Пробелов больше нет');

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?