В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tanecka2
tanecka2
28.10.2022 22:38 •  Информатика

Составить программу для нахождения для данного натурального числа сумму его чётных делителей

Ответ:
Георгий0015
Георгий0015
11.06.2020 04:06

var

a,i,res: integer;

begin

writeln('Введите число');

readln(a);

for i:=1 to a do

begin

if i mod 2=0 then

begin

if a mod i=0 then res:=res+i;

end;

end;

writeln(res);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?