В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
superplay06
superplay06
10.10.2020 23:10 •  Информатика

В массиве хранится информация о возрасте 20 учащихся случайные числа от 14 до 16. составьте программу находящую количество учащихся которому исполнилось 16 лет ответьте

Ответ:
bobbygrenn
bobbygrenn
23.11.2020 20:49

Язык Java

import java.util.*;

import java.io.*;

public class Main {

static int _16yearsOld = 0;

       

static int min = 14;

       static int max = 16;

static int diff = max - min;

static Random random = new Random();

static int rand = random.nextInt(diff + 1);

rand += min;

    public static void main(string[] args) {

       int[] students = new int[19];

for (int i = 0; i <= students.size(); i++) {

 students[i] = rand;

}

 

for (int i = 0; i <= students.size(); i++) {

 if (students[i] == 16)  

     _16yearsOld++;

}

   }

}

0,0(0 оценок)
Ответ:
svetlanasen12
svetlanasen12
23.11.2020 20:49

program z1;

const n=20;

var v:array[1..n] of integer;

i,k:integer;

begin

k:=0;

write('Массив: ');

for i:= 1 to n do

begin  

v[i]:=random(3)+14;  

write(v[i]:4);

if v[i]=16 then k:=k+1

end;

writeln;

writeln ('Количество учащихся, которым исполнилось 16 лет, ',k)

end.

Объяснение:

Переменную k увеличиваем на 1, если условие v[i] = 16 (элемент массива равен 16) истинно

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?