В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
YuliaVaskiv
YuliaVaskiv
07.01.2020 06:34 •  Информатика

Нужно составить программу. Найдите среднее арифметическое элементов массива А.
Паскаль!

Ответ:
Nurzhan2207
Nurzhan2207
19.11.2020 06:42

program svs;

const n=7;

var a:array[1..n] of integer;

i,sum:integer;

sarif:real;

begin

 sum:=0;

 sarif:=0;

 writeln ('введите массив');

 for i:=1 to n do

  begin

  write('введите A[',i,']:');

  readln(a[i]);

  sum:=sum+a[i];

  end;

 sarif:=sum/n;

 writeln ('среднее арифметическое = ',sarif:4:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?