В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

На PYTHON; Составьте программу для возведения любого числа в любую натуральную степень используя цикл FOR​

Ответ:
A1mSh1k
A1mSh1k
19.11.2020 00:19

p = int(input("Показатель степени: "))

n = int(input("Предел: "))

i = 1

while i ** p <= n:

   print(i ** p, end=' ')

   i += 1

print("\nПоследнее число,"

     " возведенное в степень:", i - 1)

Объяснение:

0,0(0 оценок)
Ответ:
Zhenya2099
Zhenya2099
19.11.2020 00:19

a = int(input("Введите число "))

c = int(input("Введите степень "))

s = 1

for i in range(c):

   s = s * a

print(s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?