В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sacredand
sacredand
27.07.2022 17:28 •  Информатика

Напишите программу на языке C++, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные:
Три целых числа вводятся в одной строке через пробелы.

Выходные данные:
Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки.

Примеры:
входные данные:
4 5 7
выходные данные:
4+5+7=16
4*5*7=140
(4+5+7)/3=5.333

Ответ:
Irina5786
Irina5786
18.11.2020 12:58

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int a, b ,c;

   cout<<"Введите 3 целых числа"<<endl;

   cin >>a>>b>>c;

   cout<<a<<"+"<<b<<"+"<<c<<"="<<a+b+c<<endl;

   cout<<a<<"*"<<b<<"*"<<c<<"="<<a*b*c<<endl;

   cout.precision(4);

   cout<<"("<<a<<"+"<<b<<"+"<<c<<")/3"<<"="<<(a+b+c)/3.<<endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?