В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SKIRLES
SKIRLES
30.07.2021 12:48 •  Информатика

Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила большее число то пользователь нажимает < если программа предложила меньшее число то пользователь нажимает > а если угадала то = тема циклы

Ответ:
Elyanoname
Elyanoname
10.06.2020 19:51

var min,max,n:integer;
c:string;
Begin
    min:=1;
    max:=1000;
    repeat
        n:=(max+min) div 2;
        writeln(n);
        read(c);
        case c of
            ">": min:=n+1;
            "<": max:=n-1;
        end
    until (c="=");
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?