В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Chokoladik
Chokoladik
12.08.2020 17:57 •  Информатика

Написать программу в паскале, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением.

Ответ:
kotelnikovsanya
kotelnikovsanya
10.06.2020 19:17

var a:array [1..100] of integer;

n,i,j:integer;

f:boolean;

BEGIN

  read(n);

  f:=false;

  for i := 1 to n do begin

    readln(a[i]);

    for j:= 1 to i-1 do

      f=f or (a[i]=a[j]);

  end;

  writeln(f);

 

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?