В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
МашунькA
МашунькA
26.01.2021 11:07 •  Информатика

2. написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Ответ:
снежок345
снежок345
30.09.2020 19:06

Var max,h:integer;

begin

max:=-maxint-1;

repeat

begin

read(h);

if(h>max) then max:=h;

end;

until h >0;

writeln(max);

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Ответ:
inara12345
inara12345
30.09.2020 19:06

using System.Collection.Generic; 

 

List<int> arr = new List<int>();

 

int max = Convert.ToInt32(Console.ReadLine()); // максимальный порог

 

for(int i = 0; i < max;i++)

{

arr.Add(Convert.ToInt32(Console.ReadLine()));

}

arr.Sort();

Console.WriteLine(arr[max]);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?