В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lololiplolpjvfhsbf
Lololiplolpjvfhsbf
13.07.2020 15:33 •  Информатика

напишите программу которая подсчитывает количество цифр в натуральном числе N введённым с клавиатуры​

Ответ:
АтинаАссорти
АтинаАссорти
15.11.2020 10:09

#include <iostream>

using namespace std;

typedef long long ll;

int main()

{

  ll number, i = 0;

  cin >> number;

  while(number > 0){

      number/=10;

      ++i;

  }

  cout << i;

}

// хитрый вариант с использованием строк на случай если число будет очень большое

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string number;

  cin >> number;

  cout << number.size();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?