В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
egorikmail826
egorikmail826
10.03.2022 01:24 •  Информатика

Составить программу ! дано натуральное число n. найти и вывести все числа в интервале от 1 до n - 1, у которых произведение всех цифр совпадает с суммой цифр данного числа. если таких чисел нет, то вывести слово "нет" пример n=44 числа : 17, 26, 35 я не разбираюсь в информатике, поэтому программу лучше сделать более доступной

Ответ:
Mariaaglotkova
Mariaaglotkova
10.06.2020 13:11

uses crt;

var n,m,i,p:longint;

   s,k:byte;

begin

clrscr;

repeat

write('Введите натуральное число N=');

readln(n);

until n>0;

m:=n;

s:=0;

while m>0 do

begin

 s:=s+m mod 10;

 m:=m div 10;

end;

writeln('Числа от 1 до ',n-1,', у которых произведение цифр=',s);

k:=0;

for i:=1 to n-1 do

begin

 m:=i;

 p:=1;

 while m>0 do

  begin

   p:=p*(m mod 10);

   m:=m div 10;

  end;

 if p=s then

  begin

   k:=1;

   write(i,' ');

  end;

end;

if k=0 then write('Таких чисел нет');

readln

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?