В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dimanichaev799
dimanichaev799
27.12.2021 06:49 •  Информатика

Напишите программу в паскале с оператором repeat дано целое число n (> 0) используя операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (n=63)

Ответ:
и5п5п
и5п5п
10.06.2020 13:08

var n,l,s,k:int64;

begin

read(n);

repeat

k:=n mod 10;

s:=s+k;

l:=l+1;

n:=n div 10;

until n=0;

write(l,' ',s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?