В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
svitlanatopp08vqs
svitlanatopp08vqs
04.10.2022 07:24 •  Информатика

Напишите программу, запрашивающую пин-код для банковской карты в виде четырехзначного числа. Считая, что в правильном пин-коде сумма первых двух цифр должна равняться сумме двух последних, выводя в случае ввода неправильного пин-кода соответствующее сообщение написать программу в Pascal ;(

Ответ:
pomosh221314
pomosh221314
15.10.2020 21:01

pascal

Объяснение:

program pincode;

var

 pin: integer;

begin

 repeat

   Write('Введите PIN-код: ');

   ReadLn(pin);

 until (length(inttostr(pin)) = 4);

 if (pin div 1000 + (pin mod 1000) div 100) = ((pin mod 100) div 10 + pin mod 10)

     then WriteLn('PIN-код верен!') else WriteLn('PIN-код неверен!');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?