В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ianna9227p00tfn
ianna9227p00tfn
08.02.2020 16:27 •  Информатика

Написать программу которая подает на вход 10 натуральных чисел . сами числа не превышают 100. если среди них есть чисел кратные 4, то вывести их сумму на экран​

Ответ:
Nataliya49017
Nataliya49017
10.06.2020 08:48

с++

#include <iostream>

#include <ctime>

using namespace std;

int main() {

srand(time(NULL));

int arr[10],sum=0;

for (int i = 0; i < 10; i++) //заполнение массива  

{

 arr[i] = rand() % 100;

}

for (int i = 0; i < 10; i++) //вывод массива

{

 cout << arr[i] << "\t";

}

cout << endl;

for (int i = 0; i < 10; i++) //узнаем кратность чисел

{

 if (arr[i] % 4 == 0) {

  sum = sum + arr[i];

 }

}

cout << sum << endl;

 system("pause");

 return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?