В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sunshinesun88
Sunshinesun88
22.07.2020 08:12 •  Информатика

Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999 (номер автобусного билета), выводит
его на экран и определяет, является ли билет «счастливым» (сумма
первых двух цифр равна

сумме последних двух цифр).​

Ответ:
frossbaf
frossbaf
07.09.2020 23:01

Var i,C,B:integer;A:Array[1..5]of integer;

Begin

 C:=1;B:=9;

 for i:=1 to 4 do

   A[i]:=random(b-c+1)+c;      

   Write('Билет-');

   For i:=1 to 4 do

    Write(A[i]);

   If A[1]+A[2]=A[3]+A[4] then Begin Writeln; writeln('Билет счастливый')end else Begin Writeln; writeln('Билет не счастливый');end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?