В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kaleksandra052
kaleksandra052
03.06.2022 19:50 •  Информатика

Напишите программу, которая выводит на дисплей следующий график:

***
**
*
**
***


писать на python, используя вложенные циклы
Вложенные циклы.
Все звездочки (*) должны печататься одной функцией print(”*”, end=“”).

Ответ:
deniskiselev1
deniskiselev1
15.10.2020 15:46

def printGraph(size):

 for numI in range(size):

   row = ''

   for numJ in range(size - numI):

     row += '*'

   if row:

     print(row)

 for numI in range(size + 1):

   if numI == 1:

     continue;

   row = ''

   for numJ in range(numI):

     row += '*'

   if row:

     print(row)

 

print(printGraph(5))

Объяснение:


Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на pytho
0,0(0 оценок)
Ответ:
1110200
1110200
15.10.2020 15:46

n = int(input("Введите размер >>> "))

for i in range(n, 0, -1):

   print("*"*i)

for i in range(2, n + 1, 1):

   print("*"*i)

============

Не забывайте нажать " ", поставить оценку и, если ответ удовлетворил, то выберите его как "Лучший"

Бодрого настроения и добра!

Успехов в учебе!


Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на pytho
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?