В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
magomedova17102
magomedova17102
19.02.2021 11:14 •  Информатика

Python Треугольник Паскаля Даны два числа n и m. Создайте массив × и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце равны 1 (A[0][j] = 1, A[i][0] = 1). Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. Входные данные Вводятся два натуральных числа n и m , не превышающих 100. Выходные данные Выведите данный массив на экран. Примеры Ввод 3 3 Вывод 1 1 1 1 2 3 1 3 6

Ответ:
kitkinausmaeva1
kitkinausmaeva1
15.10.2020 15:44

n, m = map(int, input().split())

A = [[0]*m for i in range(n)]

for i in range(m):

   A[0][i] = 1

for i in range(n):

   A[i][0] = 1

for i in range(1, n):

   for j in range(1, m):

       A[i][j] = A[i-1][j] + A[i][j-1]

for i in range(n):

   print(*A[i])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?