В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lennyface228
lennyface228
03.04.2020 05:28 •  Информатика

как написать программу на языке c++ которая находит сумму минимального нечетного числа и максимального четного числа

Ответ:
manes345
manes345
15.09.2020 06:37

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int *mas, n, sum, max, min;

   bool f_max= false, f_min = false;

   cout<<"Введите количество элементов в массиве"<<endl;

   cin >> n;

   mas = new int(n);

   cout<<"Введите элементы"<<endl;

   for (int i = 0; i < n; i++)

       cin >> mas[i];

   cout<<"Ваш массив: "<<endl;

   for (int i = 0; i < n; i++)

       cout << mas[i] <<' ';

   max = min = mas[0];

   for (int i = 0; i < n; i++){

       if (mas[i] % 2 == 0){

           if (max <= mas[i]){

               max = mas[i];

               f_max = true;

           }

       }

       else{

           if (min >= mas[i]){

               min = mas[i];

               f_min = true;

           }

       }

       

   }

   if (f_min == false)

       min = 0;

   if (f_max == false)

       max = 0;

   sum = max + min;

   cout<<"\nСумма = "<< sum<<endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?