В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
manyna4
manyna4
24.06.2022 02:44 •  Информатика

Python Напишите программу, в которой пользователь вводит строки до тех пор, пока не будет введена пустая строка "".  При вводе каждой непустой строки, программа должна выводить "текст". 

Входные данные:

Ввод текста в отдельных строчках.

Выходные данные:

Выводить "текст" до пустой строки.​

Ответ:
wormer221
wormer221
15.10.2020 15:23

--- Python 3.8.3 ---

import typing

from typing import Callable

from typing import Any

Primitive = typing.TypeVar('Primitive', int, float, complex, str, bytes, bytearray)

def ReadSeqWhile(predicate: Callable[[Any], bool], SeqType: Primitive = int):

   '''

   Возвращает последовательность элементов в указанном типе, считываемых с клавиатуры, пока ввод удовлетворяет условию

   '''

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   InputData = ReadSeqWhile(lambda p: p != '', SeqType = str)

   for _ in InputData:

       print('text')

   

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?