В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
лисичка132
лисичка132
04.01.2023 06:42 •  Информатика

Написать программу (мини-игру) на Python "Правда/ложь". В чем задание - программа будет выводить какие-то "факты", а пользователь будет решать, правда это или ложь. У пользователя будут 3 жизни, которые при неправильном решении будут уменьшатся. Ваше задание - написать именно код этих жизней и показать на основе двух "фактов" (рандомных, например, сегодня мне Знания дают такой забавный факт - "У синего кита такие большие вены, что по ним сможет проплыть маленький ребенок" etc.), как их добавлять, ибо нужно больше чем 2. Деталь: 1) если пользователь напишет какую-то белиберду вместо Правда/неправда, программа сообщит об ошибке и попросит повторить. Очень по за реализовать такое, если возможно. Задание непривычное, но, это вам не формулы в Паскале. Тех, кто не знает, как писать код и что такое не спамить; и вообще - бегите, глупцы!

Ответ:
torebekkismetov
torebekkismetov
15.09.2020 06:35

--- Python 3.8.3 ---

import typing

from typing import List  

from typing import AnyStr

from typing import Tuple

from typing import Callable

from typing import Any

class FactPackLoader:

   def __init__(self, TrueCode: str = '1', FalseCode: str = '0', encoding: AnyStr = 'utf-8',):

       self._encoding = encoding

       self._trueAnswCode = TrueCode

       self._falseAnswCode = FalseCode

   def LoadPack(self, FactPackPath: AnyStr, AnswSplitter: AnyStr = ':: ') -> Tuple[AnyStr, int]:

       with open(FactPackPath, 'r', encoding=self._encoding) as data:

           RawData = data.read().split('\n')

       for FactPair in RawData:

           FactPair = tuple(FactPair.split(AnswSplitter))

           yield (FactPair[0], self._ToBool(FactPair[1]))

           

   def _ToBool(self, replyCode):

       if replyCode == self._trueAnswCode: return True

       return False  

def main():

   f = FactPackLoader()

   print('"Правда-Ложь"\nАвтор: KnowsUser1\nVersion: 0.0.1 Ya-Sdelyal')

   IsGameRunning = 'y'

   while IsGameRunning == 'y':

       lives = 3

       fp = input('Укажите имя файла, содержащего пак фактов:\n')

       facts = f.LoadPack(fp)

       for i, Q in enumerate(facts):

           print(f'Вопрос {i+1}:\n{Q[0]}')

           reply = True if input().lower() == 'да' else False

           if reply != Q[1]:

               lives -= 1

               print(f'Вы не поверите, но тот факт, что {Q[0]}, действительно является правдой!\nЖизней осталось: {lives}')

           else:

               print(f'Вы совершенно правы!')

           if lives <= 0:

               print('Вы проиграли')

               IsGameRunning = input('Попробуем ещё раз? Y/N\n').lower()

               break

       else:

           print('Поздравляем, вы успешно выполнили все задания из файла!')

           IsGameRunning = input('Сыграем ещё раз? Y/N\n').lower()

if __name__ == "__main__":

   main()

В файле с паком вопросов после каждого вопроса должен быть указан код ответа (по умолчанию - 1 - истина, 0 - ложь), отделённый от вопроса особым символом/набором символов (по умолчанию - ':: ')

Коды ответа при необходимости в изменении указываются при создании экземпляра FactPackLoader(), символ-разделитель - при вызове LoadPack().

По умолчанию в файле с заданиями пара вопрос ответ выглядит так:

//facts.txt

На самом деле солнце белого цвета :: 1

После "::" должен стоять пробел

P.S - Код main() можно и нужно рефакторить, ибо сейчас это нечто страшное.

P.S 2 Да, я часто обращаю внимание на плохой код людей, а сейчас сам его написал. Вынепонимаете, этодругое =))

P.S 3 Проверял, программа работает. Если что то сломалось, виноват сайт. На всякий случай прикреплю файл исходного кода в .txt

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?