В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
greghs
greghs
19.09.2020 11:36 •  Информатика

Написать программу на с++ Голодная зима. Суточный рацион коровы составляет u кг сена, v кг силоса и wкг комбикорма. В хозяйстве, содержащем стадо из k голов, осталось s кг сена, t кг силоса и f кг комбикорма.. В стаде ежедневно погибает p% коров; ежедневно q% оставшегося сена сгнивает; r% силоса разворовывается колхозниками; t% комбикорма распродает зав. фермой. Когда нельзя будет кормить всех оставшихся коров по полному рациону? Какой из видов кормов кончится раньше других?

Ответ:
megasashabori
megasashabori
15.10.2020 15:00

#include <iostream>

#include <cstdlib>

#include <ctime>

#include <vector>

#include <algorithm>

using namespace std;

bool myfunction (int i,int j) { return (i<j); } // comparator

int main() {

setlocale(0, "");

srand(time(0));

float u(0.0f), v(0.0f), w(0.0f); //суточный рацион коровы, состоящий из сена, силоса и комбикорма

float k(0.0f); // колво голов в ъозяйстве

float s(0.0f), t(0.0f), f(0.0f); // сколько осталось сена, силоса и комбикорма

float percP(0.0f); //  в день погибает % коров

float percQ(0.0f), percR(0.0f), percT(0.0f); //  в день сгнивает сена, силоса и комбкорма %

int dayCounter = 0;

cout << "Сена в день: ";

cin >> u;

cout << "Силоса в день: ";

cin >> v;

cout << "Комбикорма в день: : ";

cin >> w;

cout << "Всего коров: ";

cin >> k;

cout << "Осталось сена: ";

cin >> s;

cout << "Осталось силоса: ";

cin >> t;

cout << "Осталось комбикорма: ";

cin >> f;

cout << "Сколько % в день погибает коров: ";

cin >> percP;

cout << "Сколько % пропадает сена: ";

cin >> percQ;

cout << "Сколько % пропадает силоса: ";

cin >> percR;

cout << "Сколько % пропадает комбикорма: ";

cin >> percT;

while(1) {

if(s<u) {

cout << "Кончилось сено. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

if(t<v) {

 cout << "Кончился силос. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

if(f<w) {

 cout << "Кончился комбикорм. Прожито дней: " << dayCounter << ". Осталось коров: " << k;

 break;

}

cout << "День:: " << dayCounter << "    ";

cout << "Осталось коров: " << static_cast<int>(k) << endl;

// кормим коров

s-=u;

t-=v;

f-=w;

//конец дня. Заного считаем припасы и коров.

k=k/100*(100-percP);

s=s/100*(100-percQ);

t=t/100*(100-percR);

f=f/100*(100-percT);

++dayCounter;

}

system("pause");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?