В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Андре127
Андре127
25.05.2023 14:57 •  Информатика

Напишите программу сортировки массива строк по убыванию длины (на c++).Заранее

Ответ:
IlyaLS
IlyaLS
15.10.2020 14:50

#include <iostream>

#include <vector>

using namespace std;

bool comp(string s1, string s2){

   return s1.length() > s2.length();

}

signed main() {

   int n;

   cin >> n;

   vector<string> a(n);

   for(auto &i: a)

       cin >> i;

   sort(a.begin(),a.end(),comp);

   for(auto &i:a)

       cout << i << ' ';

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?