В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
сьдвщы
сьдвщы
04.03.2022 15:42 •  Информатика

Написать программу поиска произведения последовательности отрицательных чисел, вводимых с клавиатуры, предшествующих первому введенному нулю. Контрольный пример: 1,2,3,-4,5,-2,0. С++

Ответ:
anonimus8310
anonimus8310
15.10.2020 14:44

#include <iostream>

#include <vector>

#include <algorithm>

#include <string>

#include <cstdio>

#include <math.h>

using namespace std;

int main() {

long long a, mn;

mn = 1;

cin >> a;

while (a != 0) {

mn *= a;

cin >> a;

}

cout << mn;

return 0;

}

Вроде должно работать, можешь сам протестировать)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?