В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
МОМОГИТИ1
МОМОГИТИ1
30.08.2022 14:45 •  Информатика

Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Введённые числа не превышают по модулю 90 000. Если чисел, оканчивающееся на 9, нет, то вывести «NO».

Ответ:
Rima02
Rima02
15.10.2020 14:35

#include <iostream>

#include<bits/stdc++.h>

using namespace std;

int main()

{

  int min = INT_MAX,n;

  cin>>n;

  while (n != 0)

  {

      if (n%10==9)

      {

          if (n < min)

           min = n;

      }

      cin>>n;

  }

 

  if (min == INT_MAX)

       cout<<"No"<<endl;

  else

       cout<<"min = "<<min<<endl;

 

 

 

   return 0;

}

Объяснение:


Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное числ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?